Support Center

Supported Browsers / Operating Systems

Last Updated: Sep 14, 2016 08:24AM EDT
Browser Compatibility Statement
 
We recognize that our users may have various Internet Browsers and Operating Systems. We like our clients to have the best possible experience on the web when using our product. However, we do recognize that it is impossible to develop applications that work identically, efficiently and effectively on all web browsers.

Compatible
The below list serves as the Minimum Technical Standards for the provided services: As a client of VENZA®, in order to use the Software, a user must utilize a supported browser with the latest version of Adobe Flash (and a minimum screen resolution of 1024 X 768).

A special note from Microsoft about the use of older, unsupported versions of IE: LINK TO ARTICLE

Windows 7+
  • IE 11
  • Firefox 38+
  • Chrome 40+
  • Safari 5
  • Microsoft Edge

Semi-Compatible
The browsers below may be used, but results vary based on user's configuration. Known issues have been recorded using these browsers.

Windows
  • IE 9 is only supported on Windows Vista (support ends April 2017)

Apple OS 10.10 +
  • Safari 7+
  • Opera 40

iPad / iPhone
  • Puffin

Android
  • Chrome
  • Firefox
  • Opera

Incompatible
Mobile Apple platforms for Flash-based courses, using any browser other than Puffin.

Contact Us

venzahelpdesk@gmail.com
https://cdn.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete